Keyboard layout change in Ubuntu

I’ve had this problem a couple of times in my Ubuntu machine. I installed it with US keyboard layout, and then changed it to UK later (for my user). Even when I select the correct keyboard model (Generic 105-key (Intl) PC), and layout (United Kingdom International) some keys still act weirdly (e.g. pressing ” does nothing, and if I press it twice I get a strange “-like symbol). I fixed it by running:

sudo xmodmap /usr/share/xmodmap/

26 thoughts on “Keyboard layout change in Ubuntu”

  1. the ¨¨ thing is caused by the International layout – pressing ‘ and then a will make á.

  2. Seems to fix a problem i had on my Norwegian PC as well.
    øøøææææÆÆÆ back again.

  3. I have a Compaq Presario R3000 lap top. I can not seem to get the layout right no matter what. I purchased it in Canada. I guess the layout is the same as US. Non of my SHIFT characters are correct and i am missing @ from the keyboard entirely. Any suggestions?

  4. Thanks, this solved my problem when nothing else could. By the way I needed my slovenian configuration by changing last two letters into si. THANKS REALLLLY

  5. I’d like to use ubuntu with at least 3 language layouts without having to write scripts if possible. Is there any option like in windows where you can change with alt-tab?

  6. Hi Peter, the “Keyboard Indicator” applet might help, but I’ve no idea really I’m afraid. You can install that by right-clicking on the Panel, choosing “Add to Panel…” and then clicking “Keyboard Indicator”, then “Add”. Good luck!

  7. Muchas gracias :) That’s what i’ve been looking for. If i find a hotkey for the function, i’ll post it here. thx again :)

  8. Hi andy and others, i have installed ubuntu in my DELL INSPIRON-1525, my keys are not working inside terminals.. Backspace is not functioning and many more strange symbols.. i have a layout of USA and DELL in my settings.. help me out.. thank you..

  9. Thanks, that solved my problem of not having all this bountiful polish characters as well!

  10. I was so glad to get your message about sudo xmodmap

    Now at least I can do ‘ and ` and ~ and ^ but now ” and @ are reversed. I’ll try some other layouts. . . .I guess I can learn to substitute shift-2 for shift-

    I’m on a Dell Inspiron

  11. Actually, it seems I’ll have to run the sudo xmodmap every time I boot. Is there any way I can get it into a config.sys or autoexec.bat, to use a couple of ancient terms?

  12. andy balaam, yes!, this was a great help indeed, should be more widely known one, I am using Linux for 10 years and never got to it…Thanks! Croatian and Polish, with mandarin (zhujin), really good.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.